[Fix PHPMYADMIN] Файл конфігурації тепер потрібен секретний пароль (blowfish_secret)

якщо встановленийPHPMYADMIN сервер Ubuntu, CentOS або т.п. м'яка фетровий капелюх розподіл, повідомлення "Файл конфігурації тепер потрібен секретний пароль (blowfish_secret)«У мінусі в нижній частині індексу, клопоту. Особливо, коли вона налаштована правильно "/etc/phpMyAdmin/config.inc.php".
Звичайно, шлях може змінюватися від однієї конфігурації до іншої, але 7 CentOS cu PHPMYADMIN встановлюється за допомогою "ням«В»remi.repo«Конфігураційний файл буде знаходитися в" / і т.д. / PhpMyAdmin / ».

Добре, давайте подивимося, як ви справляєтеся "Файл конфігурації тепер потрібен секретний пароль (blowfish_secret)«Якщоconfig.inc.php ми маємо наступний рядок:

$ Cfg [ 'blowfish_secret'] = '$ gNsWq $% #% #% EDFSsffsegbVp6LCJw6w'; / * Ви повинні заповнити ЦЕ ДЛЯ COOKIE AUTH! * /

Якщо цей рядок присутній і у нас є «ключ» над символами 32 в PhpMyAdmin червоному повідомлення повинно зникнути.
У разі, якщо цього не відбулося, ви повинні видалити кукі з браузера і вийти з PhpMyAdmin. При наступному вході в систему, повідомлення "Файл конфігурації тепер потрібен секретний пароль (blowfish_secret)«Я не буду присутній.
Хоча бувають ситуації, в яких він присутній не через неправильної конфігурації файл config.inc.php, але через дозволу папки, коли він був.

Запуск в командному рядку терміналу:

 корінь Чаун -R: Nginx / і т.д. / PhpMyAdmin /

Тепер все має бути добре. Якщо ви використовуєте Apache, замість користувача: nginx, встановіть "httpd" або як у вас є користувач веб-процесу на сервері.

Я написав це поради, тому що я розвернувся через 2 годин по всій конфігурації PhpMyAdmin, і до сих пір не можу уникнути повідомлення: Файл конфігурації тепер потрібен секретний пароль (blowfish_secret). Після того, як вирішені дозволу / групи, зник.

[Fix PHPMYADMIN] Файл конфігурації тепер потрібен секретний пароль (blowfish_secret)

Про автора

Stealth LP

Засновник і головний редактор налаштування StealthУ день 2006.
Досвід в операційних системах Linux (зокрема, CentOS), Mac OS X, Windows XP> Вікна 10 і WordPress (CMS).

Залишити коментар