ВИПРАВЛЕНО ПРОБЛЕМУ: на вашому сервері працює PHP версії 5.1.6, але WordPress 3.2.1 вимагає принаймні 5.2.4.

Зауваження для не все так добре відомо, що для встановлювати або зробити модернізаціяДля нової версії 3.2Це необхідно, щоб бути встановлена ​​більш нова версія 5.2.4.

Якщо сервер встановити версію PHP старше 5.2.4, установка версії WordPress 3.2.1З'являться помилка / повідомлення: "Ваш сервер працює під керуванням PHP версії 5.1.6, але WordPress 3.2.1 вимагає принаймні 5.2.4».
Проблема може бути вирішена дуже простого оновлення PHP, але перед цим кілька речей, повинні бути розглянуті. По-перше, оновити PHP можна на віртуальний хостинг. Щоб оновити, ви повинні мати доступ до administrator на сервері (Виділений сервер або VPS). У другому, перед оновленням слід документувати і знати, що нова версія PHP не давати Помилки інших сайтів, розміщених на цьому сервері.

для операційна система використовується для веб-сервери (Agreart і / WHM) Покаже вам, як це зробити оновити PHP до версії 5.2.10 CentOS 5.x 32-розрядна.

Оновіть PHP 5.1.x до 5.2.x CentOS 5.x 32-розрядна

1. Перевірити, які пакунки / модулі встановлюються PHP (наприклад, PHP-Mcrypt) на додаток до стандартних пакетах. Якщо вони існують, будуть видалені або actuzlizate.

Перевірка встановлених пакетів:

rpm -qa | grep php
old_php_version

2. Підключити додаткові репозитарії Потрібен модернізація'З PHP версії.

nano /etc/yum.repos.d/CentOS-Testing.repo

Новий файл (CentOS-Testing.repo) Додає наступні рядки (копіювати / вставити):

[c5-testing] 
name=CentOS-5 Testing 
baseurl=http://dev.centos.org/centos/$releasever/testing/$basearch/ 
enabled=1 
gpgcheck=1 
gpgkey=http://dev.centos.org/centos/RPM-GPG-KEY-CentOS-testing 
includepkgs=php*

Ctrl + X щоб зберегти файл CentOS-Testing.repo.

3. Update PHP через yum:

yum update

4. Restart / HTTPD :

service httpd restart

Після restart httpd перевірити версію та встановлені пакети:

new_php_version

Перевірте наявність помилок модулі / пакети:

php -v

- Оновлення PHP / CentOS 32-розрядний (i386).

Як записатися » Linux » ВИПРАВЛЕНО ПРОБЛЕМУ: на вашому сервері працює PHP версії 5.1.6, але WordPress 3.2.1 вимагає принаймні 5.2.4.

Засновник і головний редактор Stealth Settings, з 2006 року по теперішній час. Досвід роботи з операційними системами Linux (Особливо CentOS), Mac OS X, Windows XP> Windows 10 si WordPress (CMS).

Залишити коментар